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Introduction 
Welcome to Microsoft Word II: Advanced Features and Functions. Building on the 
foundations of Microsoft Word, this book is designed for users who are ready to dive deeper 
into the program’s more advanced features, allowing you to enhance your documents with 
sophisticated tools and techniques. 

In this guide, we will explore powerful features such as tables, columns, and mail merge, 
which can help you create professional, customized documents quickly and easily. We 
begin with tables in Microsoft Word, where you’ll learn how to add, edit, and resize 
columns and rows, as well as how to insert tables from an Excel spreadsheet. These 
features will help you manage and present data in an organized, visually appealing manner. 

We’ll also cover columns in Word, teaching you how to add or remove columns to suit 
your document’s needs. For those creating more dynamic documents, we’ll guide you 
through the mail merge process with step-by-step instructions on how to generate custom 
labels and envelopes, including adding graphic borders to enhance your designs. 

As you progress, you’ll learn how to use macros to automate repetitive tasks, speeding up 
your workflow. You’ll discover how to enable the Developer Tab, record macros, and use 
them effectively to streamline your document creation process. Additionally, we'll cover 
advanced techniques for managing multiple windows, files, and directories, including 
how to organize your files and create folders for better document management. 

By the end of this book, you will be equipped with the skills to create professional and 
efficient documents, streamline your workflow, and tackle more complex tasks in Microsoft 
Word with ease. Whether you’re preparing business reports, mailings, or personal 
documents, the tools and techniques covered in this book will ensure that your work 
stands out. 

Let’s begin our journey into the advanced features of Microsoft Word and unlock the full 
potential of this powerful software!1 

 
1 The ideas for this introduction were arranged with the help of artificial intelligence. 

 



Microsoft Word II 
 Chapter One – Tables in Microsoft Word 

 

Developed by Alicia Cota, reviewed by Andres Martinez, and produced with the assistance of the California 
Community Colleges and Imperial Valley College 

P a g e  | 7 
 

Tables in Microsoft Word 
Objectives of Chapter One 

• Add a Table 
• Insert a Table 
• Edit a Table 
• Insert a Table from Excel 

Add a Table 
In this lesson, we will explore how to add and customize tables in Microsoft Word, a 
fundamental skill for organizing and presenting information in a structured format. Tables 
are essential tools for efficiently displaying data, making it easy to compare, analyze, and 
visualize information. Whether you are creating a simple list or a more complex data set, 
Word provides a variety of options to insert and format tables according to your needs. By 
learning to add tables, you will be able to enhance your documents with clear, professional 
layouts, and effectively manage content for both academic and professional purposes.  
 
Let’s begin with the basic steps of inserting a table into your document: 

1. Identify the location to add your table, and place your cursor in that area 
2. Click on the Insert Tab on the Ribbon at the top of the window (Figure 1.1) 
3. Click on the Table icon (Figure 1.2) 
4. In the window that pops up, choose the quantity of rows and columns needed 

(Figure 1.3) 
5. The table appears on your Word document with blank cells. Begin adding your 

content. (Figure 1.4). 
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Figure1.1 The Insert Tab is on the Ribbon to the right of the Home tab. 

 

 
Figure 1.1 The Table tool is inside of the Tables group under the Insert Tab. 

 



Microsoft Word II 
 Chapter One – Tables in Microsoft Word 

 

Developed by Alicia Cota, reviewed by Andres Martinez, and produced with the assistance of the California 
Community Colleges and Imperial Valley College 

P a g e  | 9 
 

 
Figure 1.2 The Insert Table option allows the user to select the desired number of rows and columns. Click or hover over 

the white squares to add or remove rows and columns to your table. 

 
Figure 1.3 The table inserted into the Word document will look similar to the one that appears here. Content can then be 

added into each cell. 

Insert Table Dialog Box 
Instead of using the mouse to select the number of rows and columns desired, users can 
also use the “Insert Table…” dialog box. 

1. Place your cursor where you want to add your table 
2. Click on the Insert Tab on the Ribbon (Figure 1.1) 
3. Click on “Table” inside the Table Group (Figure 1.2) 
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4. Click on “Insert Table…” (Figure 1.5) 
5. A pop-up window, called a dialog box, appears. Choose the settings for your table 

(Figure 1.6) 
6. The table appears on your Word document with blank cells. Begin adding your 

content (Figure 1.7) 
 

 
Figure 1.4 The “Insert Table…” option is under  “Table” within the Insert Tab. 
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Figure 1.5 The pop up window contains the settings for the table, including table size (number of columns and rows), 
AutoFit behavior (fixed column width, AutoFit to contents, or Autofit to window), and the option to remember these 

dimensions for new tables. 

 
Figure 1. 6 The inserted table will look similar to the one that appears here. The user can add content to each box. This 

table has five columns and two rows. 

Edit a Table 
Word creates tables based on settings defined by users. A user may want to resize, add, or 
remove columns or rows after a table has been created.  

Change the Size of a Column 
1. Identify the column that you want to change. 
2. Move your mouse to the top of the right or left line that defines that column. 
3. The pointer will change form from an arrow to two vertical parallel lines with two 

arrows that point in opposite directions. 
4. With the pointer in its new form, click on the line and hold the left mouse button as 

you move the mouse to resize the width of the column. 

Change the Size of a Row 
1. Identify the row that you want to change. 
2. Move your mouse to the line defining the top or bottom of the row. 
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3. Wait for the pointer to change its form to two parallel lines and two arrows pointing 
opposite directions. 

4. With the pointer in its new form, left click and hold to drag the line to resize as 
needed. 

Add a Column 
1. Identify the position where you want to add a column.  
2. Move your mouse to the top of the table and hover over the column border to the left 

of where you want to add your column. 
3. The column border will turn blue and the image of a plus sign inside a circle will 

appear at the top of the table. 
4. Click on the plus sign to add a column to the right. 

Add a Row 
1. Identify the position where you want to add a row.  
2. Move your mouse to the left edge of the table and hover over the line below which 

you want to add a row. 
3. The row border will turn blue and the image of a plus sign inside a circle will appear 

to the left of the table. 
4. Click on the plus sign to add a row below the current location. 

Insert a Table from Excel Spreadsheet 
Microsoft Word allows for the easy inclusion of many Microsoft Excel tools. You can create 
a report in Microsoft Word that include tables, charts, formulas with the versatility of 
Microsoft Excel. 

Add a Table 
1. Identify the place in your Word document that you would like to add a table and 

place your cursor in that area. 
2. Click on the Insert Tab on the Ribbon (Figure 1.1). 
3. Click on the Table tool inside the Tables group (Figure 1.2). 
4. Click on Excel Spreadsheet (Figure 1.8). 
5. The Excel table appears in your Word document with blank cells. This is where you 

would add your information (Figure 1.9) 



Microsoft Word II 
 Chapter One – Tables in Microsoft Word 

 

Developed by Alicia Cota, reviewed by Andres Martinez, and produced with the assistance of the California 
Community Colleges and Imperial Valley College 

P a g e  | 13 
 

6. Note that when the Excel table is active, the Excel Ribbon is shown instead of the 
Word Ribbon. 

7. Figure 1.10 shows a table created using the Excel spreadsheet tool. Notice that 
some cells have been formatted with a black border but that other, blank, cells are 
also visible. The size of the Excel window can be adjusted to your own preference. 
By default, Excel cell borders don’t print.  

8. Figure 1.11 shows a chart generated from the information in the Figure 1.10 table. 

 
Figure 1.7 The Insert Table menu includes “Excel Spreadsheet” as an option. 
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Figure 1.8 A blank Excel spreadsheet inserted into a Word document. When the window is active, it shows Excel columns, 

rows, and sheets. 

 

 

 

 

 
Figure 1.9 Table created using an Excel Spreadsheet. 

 

Dress 
Sizes Quantity
XS 15
S 20
M 30
L 7
Total 72
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Dress Sizes

XS S M L
 

Figure 1.10 Chart created using an Excel spreadsheet based on the data in the table in Figure 1.10. The Insert tab on the 
Excel Ribbon includes chart options.
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Columns in Microsoft Word 
Objectives of Chapter Two 

• Add a Column 
• Remove a Column 

Add a Column 
In this chapter we are going to talk about columns in Microsoft Word. Columns can help 
chunk information. Usually you will input text first and then create the columns. In this 
example we are going to create three columns. 

1. Type the information, separating each paragraph by hitting the Enter key at the end 
1. of each. In this exaple, we have three paragraphs. 
2. Select all the text to be converted to columns. 
3. On the Layout tab on the Ribbon, select the Columns tool in the Page Setup 

group. Click the down arrow to expand the menu and select “Three” under number 
of columns (Figure 2.1). 

4. If you are using columns to chunk information, the paragraphs should be similar 
lengths to create similar columns. 
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Figure 2.1. Select “Three” on the Columns pull-down menu to create three columns.  

Below is an example using the description of the course typed out into three separate 
paragraphs to demonstrate step six: 

Direct practice with Microsoft Word. Word is a processing software using a windows 
environment. The course is a continuation of CIS 120, Microsoft Word, and will 
focus on editing and formatting features including multiple windows and 
documents, managing files, tables, columns, merge, labels, sort, and graphics. (C-
ID: BSOT 121 X) (CSU) 

Direct practice with Microsoft Word. Word is a processing software using a windows 
environment. The course is a continuation of CIS 120, Microsoft Word, and will 
focus on editing and formatting features including multiple windows and 
documents, managing files, tables, columns, merge, labels, sort, and graphics. (C-
ID: BSOT 121 X) (CSU) 

Firsthand practice with Microsoft Word. Word is a processing software using a 
windows environment. The course is a continuation of CIS 120, Microsoft Word, and 
will focus on editing and formatting features including multiple windows and 
documents, managing files, tables, columns, merge, labels, sort, and graphics. (C-
ID: BSOT 121 X) (CSU) 
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Below is an example of how the columns look after following steps three and four:  

Firsthand practice with 
Microsoft Word. Word is 
a processing software 
using a windows 
environment. The course 
is a continuation of CIS 
120, Microsoft Word, and 
will focus on editing and 
formatting features 
including multiple 
windows and 
documents, managing 
files, tables, columns, 
merge, labels, sort, and 
graphics. (C-ID: BSOT 
121 X) (CSU ) 

Firsthand practice with 
Microsoft Word. Word is 
a processing software 
using a windows 
environment. The course 
is a continuation of CIS 
120, Microsoft Word, and 
will focus on editing and 
formatting features 
including multiple 
windows and 
documents, managing 
files, tables, columns, 
merge, labels, sort, and 
graphics. (C-ID: BSOT 
121 X) (CSU) 

Firsthand practice with 
Microsoft Word. Word is 
a processing software 
using a windows 
environment. The course 
is a continuation of CIS 
120, Microsoft Word, and 
will focus on editing and 
formatting features 
including multiple 
windows and 
documents, managing 
files, tables, columns, 
merge, labels, sort, and 
graphics. (C-ID: BSOT 
121 X) (CSU) 

Remove Columns 
Distributing information in your document is vital. Setting up columns to chunk information 
can be tricky, and at times you may need to remove and/or adjust the number of columns. 
To reduce the number of columns, follow these steps:  

1. Select the three columns. 
2. On the Layout tab on the Ribbon, select the Columns tool in the Page Setup group. 

Click the down arrow to expand the menu and select “Two” under number of 
columns (Figure 2.2). 

3. By default, Word makes the columns equal length. In our example, the first half of 
the second paragraph is in the first column, while the second half of the second 
paragraph is in the second column. 

4. To remove the columns, select the text and follow the instructions in step 2, 
4. selecting “One” instead of “Two” (Figure 2.3). 
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Figure 2.1 Select “Two” on the Columns pull-down menu to create two columns. . 
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Figure 2. 2 Select “One” on the Columns pull-down menu to return to a single column.  

Below is an example of how the columns look after following step two. 

Firsthand practice with Microsoft Word. 
Word is a processing software using a 
windows environment. The course is a 
continuation of CIS 120, Microsoft Word, 
and will focus on editing and formatting 
features including multiple windows and 
documents, managing files, tables, 
columns, merge, labels, sort, and 
graphics. (C-ID: BSOT 121 X) (CSU) 

Firsthand practice with Microsoft Word. 
Word is a processing software using a 
windows environment. The course is a 
continuation of CIS 120, Microsoft Word, 
and will focus on editing and formatting 
features including multiple windows and 

documents, managing files, tables, 
columns, merge, labels, sort, and 
graphics. (C-ID: BSOT 121 X) (CSU) 

Firsthand practice with Microsoft Word. 
Word is a processing software using a 
windows environment. The course is a 
continuation of CIS 120, Microsoft Word, 
and will focus on editing and formatting 
features including multiple windows and 
documents, managing files, tables, 
columns, merge, labels, sort, and 
graphics. (C-ID: BSOT 121 X) (CSU)
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Merge in Microsoft Word 
Objectives for Chapter Three 

•  Use the Mail Merge Wizard 
a. Create a letter 
b. Generate a list of contacts 
c. Work with merge wizard 

Step by step mail merge wizard 
Time is the most precious resource, and understanding how to use mergers is a great 
timesaver. Mail Merge allows you to quickly customize letters, emails, etc. By following five 
simple steps you can make your work look professional with less time and effort (Figure 
3.1). 

 

Figure 3.1 A formal letter with the recipient’s address at the top and a greeting line before the body of the message. Mail 
Merge allows these fields to be automatically populated from an existing database.  
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To customize your own document: 

1. Open or create the document that you want to customize. It should contain the 
body text of the letter you wish to send. 

2. From the Mailings Tab on the Ribbon, click on Start Mail Merge (Figure 3.2). 
3. From drop-down menu, click on Step-by-Step Mail Merge Wizard (Figure 3.3). 
4. The Mail Merge Wizard will open in a pane on the right side of the screen. Begin by 

selecting the document type. In this example it is a letter (Figure.3.4). 
5. Click “next” at the bottom of the window.  
6.  Choose a type of document. For this example, we are going to select “Use the 
6. current document” (Figure 3.5). Other options include starting from a template or 
6. using a preexisting document. Click “next” at the bottom of the window. 
7. Select the recipients for your letter. You can use an existing list, but for this example, 

we will choose “Type a New List” (Figure 3.6). Click “Create” to generate the file. 
8. In the New Address List pop-up window, enter the recipient information. Complete 

each of the columns, with one recipient per row (Figure 3.7). Click “New Entry” to 
add each new recipient. Click the “OK” button to save the list of clients in the 
desired location (Figure 3.8). 

9. In the Mail Merge Recipients pop-up window, put a check box beside each desired 
recipient (Figure 3.9), then click the “OK” button. 

10. The Wizard pane on the right will now show the name of the address file (Figure 
10. 3.10). Click “next” at the bottom of the pane. 
11. In your document, click where you wish to insert the address information. In the 

Wizard pane, Click “Address Block” to open the pop up window (Figure 3.11). 
12. In the Insert Address Block pop-up window that opens, select your preferred 

format (Figure 3.12) and click the “OK” button. In your document, “«AddressBlock»” 
will appear as a placeholder. 

13. Position your cursor in the desired location on your document and repeat the steps 
to add a greeting line, electronic postage, or more (Figure 3.11) 

14. Click “next” at the bottom of the window to preview the letter. 
15. Your document will now show the placeholder fields replaced by real information, 

beginning with the first recipient from your list. In the pane, you can use the left and 
right arrow buttons to scroll through all recipients. 

16. Click on the next at the bottom of the pane to complete the merge. 
17. In the last step you can print or edit each of the merged letters (Figure 3.13). 
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Figure 3. 2 The “Start Mail Merge” tool is  on the Mailings Tab of the Ribbon. 

 
Figure 3. 3 From the pull-down menu, select "Step-by-Step Mail Merge Wizard.” 
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Figure 3. 4 Select “Letters” for the Mail Merge document type. 
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Figure 3.5 Select “Use the current document.” 

 

 
Figure 3.6 Select recipients list. In this example we will use “Type a new list.” 
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Figure 3. 7 Fill in each column (Title, First Name, Last Name, etc.), with one recipient per row.  

 

 
Figure 3.8 Identify the desired location for your address list and click “Save.”  
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Figure 3.9 In the Mail Merge Recipients window, place a check mark beside desired recipients (or check the box in the 

header row to select all). 

 
Figure 3.10 In the Wizard pane, the name of the address file to be merged is shown in quotation marks. 
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Figure 3.11 “Address block,” “Greeting line,” and more are placeholders that can be added to the document. Click on each 

to open a pop-up window to make customizations. 

 
Figure 3.12 The “Insert Address Block” window allows the user to format recipients’ names and how addresses appear. 
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Figure 3.13 In the last step of Mail Merge, the user can either print the letters or edit individual ones. 
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Merge Labels Wizard 
Objectives for Chapter Four 

• Use the Mail Merge Wizard for labels 
a. Create a letter 
b. Generate a list of contacts 
c. Work with Merge Wizard 

Step by Step Mail Merge Wizard for Labels 
Creating labels one by one and figuring out how to print them correctly can be difficult and 
time-consuming. Microsoft Word’s Mail Merge Label Wizard can help accomplish the 
label setup in less than five minutes. The best part is that Wizard provides seamless setup 
for multiple commercial label options (Figure 4.1). 

 
Figure 4.1 Example of addresses set up for printing on a particular brand of address labels that include 10 labels per 

sheet. You can customize your setup depending on the type of label you have and your needs. 

 



Microsoft Word II 
 Chapter Five – Envelope Setup & Graphic Border 

Developed by Alicia Cota, reviewed by Andres Martinez, and produced with the assistance of the California 
Community Colleges and Imperial Valley College 

P a g e  | 31 
 

 

1. Open a blank document. 
2. Click on Start Mail Merge from the Mailings Tab on the Ribbon (Figure 4.2). 
3. Click on Step-by-Step Mail Merge Wizard on the pull-down menu (Figure 4.3). 
4. The Wizard pane will open on the right side of the screen. This time, instead of 
4. Letters, select Labels (Figure.4.4). Click “next” at the bottom of the window.  
5. Choose a starting document. Under the Change Document Layout header, click on 

the “Label options” link (Figure 4.5). This will open a pop-up window that allows you 
to select the label product you’ll be printing on. Select the vendor first, then the 
product number or size (Figure 4.6). Choose a product and click the “OK” button to 
close the window. 

6. Your document will update with the dimensions of the labels you’ve selected. Click 
“next” at the bottom of the Wizard pane. 

7. Next, select a recipients list. In this example, we are going to use the option “Use an 
Existing List” (Figure 4.7) and then click “Browse” (Figure 4.8). 

8. In the pop-up window, select your recipient address file (Figure 4.9) and click 
“Open.”  

9. If your address file is an Excel spreadsheet, a “Select Table” window will pop up 
(Figure 4.10). Once you click “OK,” a “Mail Merge Recipients” pop-up will open. As 
described in the last chapter and shown in Figure 3.9, select your recipients and 
select “OK.” 

10. Your document will now show the placeholder text “«Next Record»” in each label 
space after the first space, where your cursor is now located (Figure 4.11). 

11. Click “Next” at the bottom of the Wizard pane to arrange your labels. 
12. As we did in the last chapter, click on Address Block (Figure 4.12) to open the 

Address Block window, which contains a preview of how the information will 
appear (Figure 4.13). Depending on the structure of your address file, you may need 
to click the “Match Fields” button and use the dropdown menus to import the 
information correctly. Click the “OK” button to save your changes and close the 
window. 

13. The first label now shows the placeholder text “«AddressBlock», while the rest still 
13. say «Next Record»” (Figure 4.14). To update the remaining fields, click on the 
13. “Update all labels” button (Figure 4.15). Now the rest of the labels also read «Next 

Record»«AddressBlock». Click Next at the bottom of the pane. 
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14. Your document will now show a preview of your populated labels (Figure 4.1). In the 
14. Wizard pane, click Next to complete the merge and edit individual labels or print 
14. them.  

 
Figure 4.2 From the Start Mail Merge Group on the Mailings Tab of the Ribbon, click “Start Mail Merge.” 
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Figure 4.3 In the pull-down menu, select Step-By-Step Mail Merge Wizard.  

 
Figure 4.4 Choose “Labels” to format printing to a particular commercial label. 
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Figure 4.5 Click “Label Options” to open a pop-up window that allows you to select a specific commercial label. 

 
Figure 4.6 In the Label Options pop-up window, select the vendor/brand and then the product number for the labels you 

have. Confirm that the dimensions of the label match your physical labels. 
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Figure 4.7 The “use existing list” option allows users to populate the address information from an existing database or 

spreadsheet. Users can also opt to type a new list instead.  

 

 
Figure 4.8 Under the “Use an existing list,” header, click “Browse” to locate the desired address file. 
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Figure 4.9 In the “Select Data Source” pop-up window, search for or navigate to the address file. 

 
Figure 4.10 If the chosen address file is a spreadsheet, the “Select Table Tool” pops up. Uncheck the option “First row of 

data contains column headers” if this is not the case for your particular file. Click OK to continue. 



Microsoft Word II 
 Chapter Five – Envelope Setup & Graphic Border 

Developed by Alicia Cota, reviewed by Andres Martinez, and produced with the assistance of the California 
Community Colleges and Imperial Valley College 

P a g e  | 37 
 

 

 
Figure 4.11 Preview of the label layout, with the first one blank and the following ones showing the placeholder «Next 

Record». 
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Figure 4.12 Click on “Address block” to add this field to your labels and customize its appearance. 

 

 
Figure 4.13 The “Insert Address Block” pop-up window gives options for formatting recipient names and addresses. If the 
information in the preview box on the right is incomplete, click “Match Fields” to make sure the address block is pulling in 

the correct address elements from your file. 
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Figure 4.14 The first label now shows «Address Block» and the subsequent labels just show the placeholder text «Next 

Record». Click “Update all labels” to fill them all with the placeholder text «Address Block»«Next Record». 

 

 
Figure 4.15 Update All Labels button is a funtion that copies all previous information from the first label to the rest of the 

labels 
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Envelope Setup, Graphic Border 
Objectives for Chapter Five 

• Set up an envelope step by step 
• Add a graphic border to a page 

Step-by-Step Envelope Setup 
Microsoft Word has tools to design effective and attractive envelopes. This chapter will 
help you develop the skills to create and print them as smoothly and quickly as possible. 
(Figure 5.1). 

 
Figure 5.14 An example of a print-ready envelope with recipient and return addresses. 

1. Open a blank document. 
2. In the Mailings Tab on the Ribbon, click Envelopes in the Create group (Figure 5.2). 
3. An “Envelopes and Labels” pop-up window will appear (Figure 5.3). Enter the 

delivery address and return address in their respective boxes. 
4. Click the “Options” button to open a pop-up window that allows you to specify the 

envelope dimensions and other printing options (Figure 5.4). 
5. Select “Print” to send the final product to the printer (Figure 5.5). 
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Figure 5. 15 The Envelope Tool is located inside of the Create Group on the Mailing Tab. 

 
Figure 5.2 The “Envelope and Labels” pop-up window includes areas to enter the delivery and return addresses.  
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Figure 5.3 The “options” button opens another pop-up to specify envelope dimensions, fonts, and printing options. 

 
Figure 5.4 Clicking the “print” button will send the envelope to the specified or default printer. 
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Add Graphic Borders to a Page 
Borders in Microsoft Word can enhance the visual appeal of your documents, giving them 
a polished and professional look. Whether you are working on a report, letter, or invitation, 
adding a border can help to frame your content or highlight important sections. Microsoft 
Word provides options for creating borders, ranging from simple page borders to more 
customized designs for specific paragraphs or sections. In this guide, we will walk through 
the simple steps to add a border to your document and tailoring your borders to suit your 
needs. (Figure 5.6). 

 
Figure 5.6 This decorative border, created in Word, features multiple parallel lines and nested circles at the corners. 

1. Open a blank document. 
2. Go to the Design Tab on the Ribbon. 
3. In the Page Background Group, click the Page Borders tool (Figure 5.7). 
4. Under “Setting,” choose one of the border options (None, Box, Shadow, 3-D, and 

Custom) (Figure 5.8) 
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5. Select a style for your border (Figure 5.9), which may include solid, dotted, dashed, 
and/or multiple lines. 

6. Customize your border using the Color and Width options 
7. For an image border, like the one shown in Figure 5.6, use the Art pull-down menu. 
8. In the “Apply to” pull-down menu, specify where to apply the border: “Whole 

document,” “This section,” “This section – First page only” and “This section – All 
except first page” (Figure 5.10). Click “OK” to apply the selected border. 

 
Figure 5.7 The Page Borders is located at the far right end of the Design Tab on the Ribbon. 

 

 
Figure 5.8 The “Borders and Shading” pop-up window includes options for border type, style, color, width, and art. A 

Preview box on the right previews the chosen options. 
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Figure 5.9 The “Style” menu includes solid, dotted, dashed, and compound line options. 
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Figure 5.10 The “Apply to” drop-down menu allows the user to select the region for the border.  
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Macros 
Objectives for Chapter Six 

• Understand what a macro is 
• Enable the Developer Tab 
• Record a macro 
• Use a macro 

What is a Macro? 
Macros in Microsoft Word are powerful tools that allow you to automate repetitive tasks by 
recording a sequence of actions that can be played back later. They’re especially useful for 
tasks that you perform often, such as formatting documents, inserting standard text, or 
applying a specific layout. 

For example, think of a user who includes a full signature, complete with contact 
information, at the end of every letter she writes. Let’s say that this person types her 
signature information manually. It would be amazing if she could type just two or three keys 
and have all the information automatically appear! This is where macros come into play. 
Macros record a sequential set of actions and assign this sequence to a specific keyboard 
command or button. 

Let’s walk through the process of creating a macro using the example of automatically 
inserting that signature information. We’ll use the information below: 

Alicia Paola Cota 
Imperial Valley College 
Computer Information System Instructor 
alicia.cota@imperial.edu 
(555) 555-5555 
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Enable the Developer Tab 
The user can always record a Macro from the View tab on the Ribbon. However, the 
Developer tab offers more options and possibilities, so we’ll start by enabling it. It requires 
a few steps to uncover: 

1. In the gray toolbar at the top of the window, just to the left of the name of the file you 
have open, is a down arrow with a line above it (Figure 6.1). Click that arrow to open 
the Customize Quick Access Toolbar drop-down menu. 

2. From this menu, click on More Commands (Figure 6.2). 
3. A Word Options pop-up window will appear. From the options on the left side, click 

on Customize Ribbon (Figure 6.3). 
4. From the “Customize the Ribbon” options on the right side, under the Main Tabs 

menu, click the checkbox beside Developer to activate it, then click the “OK” 
button to save your changes (Figure 6.4). 

 
Figure 6.1 The Quick Access Toolbar drop-down menu is located in the gray toolbar at the top of the window, between the 
“Repeat Typing” curved arrow and the name of the current file, and is marked by a down arrow with a straight line over it.  



Microsoft Word II 
Chapter Six – Macros 

Developed by Alicia Cota, reviewed by Andres Martinez, and produced with the assistance of the California 
Community Colleges and Imperial Valley College 

 P a g e | 50 

 

 

 

Figure 6.2 In the expanded menu, “More Commands” is the third option from the bottom. 
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Figure 6.3 The Customize Ribbon option is under Word Options on the left side of the window, between the options 

Advanced and Quick Access Toolbar. 



Microsoft Word II 
Chapter Six – Macros 

Developed by Alicia Cota, reviewed by Andres Martinez, and produced with the assistance of the California 
Community Colleges and Imperial Valley College 

 P a g e | 52 

 

 

 
Figure 6.4 To activate the Developer tab on the ribbon, click the checkbox beside “Developer” on the list under Customize 

the Ribbon on the right side of the window. Note that you may need to scroll down in the list to find it. 

Record a Macro 
 Now that we’ve enabled the Developer tab, we can get into the magic of macros! 
Recording a macro requires identifying when it begins, where it ends, and what it should do 
in-between. This section will describe the start, processing, and ending steps.  

1. Click on the Developer tab now visible in the Ribbon (Figure 6.5). 
2. In the Code group, click on Record Macro (Figure 6.6). 
3. A Record Macro pop-up window will appear (Figure 6.7). Type the name of the 

macro in the Macro name space. Then choose how the macro will activate by 
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selecting one of the options (Button or Keyboard) under Assign Macro To. Our 
recommendation is to select Keyboard. 

4. Clicking "Keyboard" will open a new pop-up window called Customize Keyboard. 
Click in the area under “Press New Shortcut Key” and press the keys that will 
activate your macro (Figure 6.8). In this example, we have held down the Alt key 
while hitting the s key. Click on the “Assign” button (Figure 6.9) and then the “Close” 
button to save the macro. This is the last step of activating the macro. 

5. Once you close the window, you will see that the pointer image now includes a 
cassette tape, indicating that the macro is recording your actions (Figure 6.10). At 
this point, begin typing or performing the action you want the macro to reproduce by 
itself, such as typing the signature information shown previously. 

6. When you have completed the desired action for the macro to reproduce, click Stop 
Recording (Figure 6.10). You can also pause recording at any time by clicking Pause 
Recording (Figure 6.11) and then Resume Recorder when you’re ready to continue.  

7. To manage your macros, click on the Macros tool in the Code Group on the 
Developer tab on the Ribbon. 

 

 
Figure 6.5 The Developer tab was previously hidden, but once activated, it is visible between the View and Help tabs.  

 

 
Figure 6.6 The Record Macro tool is under the Code group on the Developer tab. 
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Figure 6.7 The Record Macro window allows you to assign a macro name and identify how you want to activate the macro. 

 
Figure 6. 8 In the Customize Keyboard window, establish the shortcut key that activates the macro. 
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Figure 6.9 The “Assign” button is at the bottom left of the Customize Keyboard window and the “Close” button is at the 

bottom right of the same window. 

 

 
Figure 6.10 The pointer includes the image of a cassette tape to indicate that a macro is being recorded. 
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Figure 6.11 The Stop Recording tool is in the Code group on the Developer tab and stops recording of the macro.  

 
Figure 6.12 The Pause Recording tool is in the Code group on the Developer tab and pauses recording of the macro . 

Use a Macro 
Once you’ve created a macro, the only action required for the software to activate the 
macro is to click the key command assigned to the macro. In this example we just 
described, the keystrokes alt + s pastes in the full signature information shown earlier.
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Multiple Windows, Manage Files and Directories  
Objectives for Chapter Seven 

• Manipulate Multiple Windows in a Screen 
• Manage Files and Directories 

How to Manipulate Multiple Windows in a Screen 
Being able to manipulate multiple windows is beneficial when working on a laptop or 
smaller screens. Displaying two windows in a single screen is as easy as holding down the 
Windows key on the keyboard while clicking the right or left arrow. This action allows you 
to divide the screen into two and move your current window to the right or left. Figure 7.1 
shows my screen with only one window displayed. Figure 7.2 shows two Windows 
displayed in a single screen after clicking the Windows key and right arrow. 

 

 
Figure 7.1 The typical view of a window displayed across the entire screen. 
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Figure 7. 2 A screen showing two windows side by side, the result of pressing Windows key + right arrow. 

Manage Files and Directories 
The ability to organize files inside folders can save a significant amount of time for users 
trying to find where their files are saved. For example, imagine a room full of clothes and 
shoes scattered all around. It will be increasingly difficult for an individual to find a specific 
item of clothing (Photo 7.1). 

 
Photo 7.1 A messy room, like the one shown, is a hard place to find a particular piece of clothing. Photo by Onur 

Bahçıvancılar on Unsplash  

https://unsplash.com/@citrusboy?utm_content=creditCopyText&utm_medium=referral&utm_source=unsplash
https://unsplash.com/@citrusboy?utm_content=creditCopyText&utm_medium=referral&utm_source=unsplash
https://unsplash.com/photos/assorted-brand-product-lot-near-window-wh9I0jokix8?utm_content=creditCopyText&utm_medium=referral&utm_source=unsplash
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The same can occur when a person is trying to find a file in a folder that does not have any 
organization. This can be exhausting and result in not being able to locate the correct file. 
To avoid these types of issues, we recommended creating one folder per topic. For 
example, in my File Explorer I have one folder per class (Figure 7.3), as you can see in the 
left pane. Within the folder “CIS121,” I have subfolders for each of the chapters of the book 
that I am writing. This organization helps me find the chapter that I need from a specific 
class, avoiding mixing the chapters between the different books.  

Directories are arrangements of different electronic addresses where a user can find a file. 
In the example below, the directory is OneDrive, then in a folder named Alicia. Inside of that 
folder is a subfolder with the name CIS121. That subfolder contains more subfolders with 
the name of each chapter. That is how I organize files, but every user has their own style. 

 
Figure 7.3 This image from File Explorer shows folders and subfolders on the left. In the left pane, the open folder is 

highlighted blue. That folder’s information is displayed in the right pane. The complete address of a folder or file is shown 
at the top of the window next to the arrows. Here, it is OneDrive > Alicia – Imperial Valley College > CIS 121 > Chapter 7. 
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How to create a folder 
Before you create a folder, identify where you want to store your work. We recommend 
saving in Documents, OneDrive, or Desktop. Each of these directories saves the folder in 
a distinct location. For example, Documents and Desktop are locations on your own 
computer’s hard drive. This location is not a sharing location, and only you have access to 
the file in the computer where the file was saved. Finally, OneDrive is an online location 
and can be accessed from any computer with proper credentials to login. Each of these 
directories can be found in the left pane of File Explorer. Once you are inside of the 
directory, follow these steps to create a folder: 

1. Select your directory. In this example, we are using OneDrive (Figure 7.4) 
2. Create a folder by clicking on “+ New” button in the toolbar at the top of the window 

(Figure 7.5). 
3. From the pull-down menu that appears, click on Folder (Figure 7.6). 
4. Name the folder (Figure 7.7). 
5. To create a subfolder inside of the current folder, go back to step 2 and follow the 

instructions again. 

Once you have created a folder, you can move files and other folders into it. Simply click on 
the desired file or folder and drag it into the chosen folder. Alternatively, right click on the 
file and choose “cut,” then right click on the desired folder and select “paste.” 
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Figure 7.4 The OneDrive directory is located in the pane at the left of the File Explore window. 

 
Figure 7.5 The “New” button is at the left of the toolbar at the top of the File Explorer window. 



Microsoft Word II 
Chapter Seven – Multiple Windows, Manage Files and Directories 

 

Developed by Alicia Cota, reviewed by Andres Martinez, and produced with the assistance of the California 
Community Colleges and Imperial Valley College 

P a g e  | 63 
 

 

 
Figure 7.6 From the “New” button pull-down menu, click on Folder to create a new folder. 

 
Figure 7. 7 To name a newly-created folder, simply begin typing. To rename a folder, click once on the folder to highlight it, 

and then click a second time. The title is now highlighted in blue and can be edited. 
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